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Remote Desktop Protocol Clients Cannot Connect to Terminal Services Server 
Remote Desktop Protocol Clients Cannot Connect to Terminal Services Server

Article ID : 270588
Last Review : September 22, 2003
Revision : 3.0
This article was previously published under Q270588
IMPORTANT: This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:
256986 (http://support.microsoft.com/kb/256986/EN-US/) Description of the Microsoft Windows Registry
SYMPTOMS
Terminal Services clients may not be able to connect to a Windows 2000-based computer that is running Terminal Services.

When you use the Terminal Services Configuration snap-in (Tscc.msc), the transport (RDP-Tcp) appears to be present and working. However, when you view the transport by using Terminal Services Manager (Tsadmin.exe), the RDP-TCP listener is reported as "Down 65536."
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CAUSE
This problem can occur if the server has been booted by using the Last Known Good Configuration option more than once. When the server has been booted into the last known good configuration more than once, the ControlSet001 registry key is deleted. However, the following registry value is hard-coded to use the ControlSet001 registry key:
Key: HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Terminal Server\VIDEO\rdpdd\

Value name: \Device\Video0
Value type: REG_SZ
Value data: \REGISTRY\Machine\System\ControlSet001\Services\RDPDD\Device0
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RESOLUTION
WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

To resolve this problem, obtain the latest service pack for Windows 2000. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
260910 (http://support.microsoft.com/kb/260910/EN-US/) How to Obtain the Latest Windows 2000 Service Pack
To resolve this problem: 1. Start Registry Editor (Regedt32.exe).
2. Locate and click the following registry key:
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Terminal Server\VIDEO\rdpdd\
Note If you do not have this key, use Registry Editor to create it.
3. Do one of the following:• If you did not have to create the key in step 2, change the following value
Name: \Device\Video0
Type: REG_SZ
Value: \REGISTRY\Machine\System\ControlSet001\Services\RDPDD\Device0
to the following:
Name: \Device\Video0
Type: REG_SZ
Value: \REGISTRY\Machine\System\CurrentControlSet\Services\RDPDD\Device0
• If you had to create the registry key in step 2, add the following value:
Subkey name: RDPDD
Name: \Device\Video0
Type: REG_SZ
Value: \REGISTRY\Machine\System\CurrentControlSet\Services\RDPDD\Device0

4. After you change (or create) the value, restart the computer that is running Terminal Services.

STATUS
Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was first corrected in Windows 2000 Service Pack 2. 
Link http://support.microsoft.com/?kbid=270588 
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